aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJJ <nicetry@noemail.com>2025-03-19 22:22:10 +0000
committerJJ <nicetry@noemail.com>2025-03-19 22:22:10 +0000
commit9a58766525f29845eaa930819e9c096b9991d6cf (patch)
tree5d9a4076495c618d59a596fc5cae678f395ef822 /pyproject.toml
first commit
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..6ecf7d1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,23 @@
+[project]
+name = "tube-stat"
+version = "0.1.0"
+description = ""
+authors = [
+ {name = "JJ",email = "nicetry@noemail.com"}
+]
+readme = "README.md"
+requires-python = ">=3.13"
+dependencies = [
+ "click (>=8.1.8,<9.0.0)",
+ "requests (>=2.32.3,<3.0.0)"
+]
+
+[tool.poetry]
+packages = [{include = "tube_stat", from = "src"}]
+
+[tool.poetry.scripts]
+tubestat = "src.tube_stat.cli:cli"
+
+[build-system]
+requires = ["poetry-core>=2.0.0,<3.0.0"]
+build-backend = "poetry.core.masonry.api"